Back
Resolved

Hapag-Lloyd Integration Downtime

Started 10 Apr at 02:46pm HDT.

Hapag-Lloyd (HLCU)
Created

The issue has been resolved, and the integration has been restored.

Posted 10 Apr at 02:46pm HDT.